Internet SOLUTIONS

Cara Membuat User Hotspot MikroTik.

[By user admin on 2015-05-16 ] EDIT

Cara Membuat User Hotspot MikroTik

Menindak lanjuti artikel saya sebelumnya, sekarang kita akan membuat user hotspot atau client yang akan mempunyai akses ke hotspot mikrotik kita untuk bisa mengakses koneksi internet. Di user management mikrotik kita bisa membuat beberapa user dengan beberapa opsi/batasan.

Users - /ip hotspot users

Di menu ini opsi konfigurasi user / password klien bisa ditambahkan
Tab “General

 

  • Server, nama server Hotspot yang diperbolehkan login untuk user.
  • Name, Username untuk login user HotSpot, jika otentikasi dengan MAC-addressdi aktifkan, di isi dengan mac address client.
  • Password, password user.
  • Address, masukan IP address yang kita tentukan untuk didapat oleh client dari server hotspot.
  • MAC Address, username diperbolehkan untuk login hanya dari MAC Address yang ditentukan.
  • Profile, User profile yang sudah di konfigurasi di /ip hotspot user profile.
  • Routes, Routing yang ditambahkan jika client terkoneksi. Format routingnya adalah dst-address gateway metric (contoh, 192.168.1.0/24 192.168.88.1 1)
  • Email, alamat email pengguna hotspot.

Tab “Limits

  • Limit Uptime, Batas Uptime untuk klien HotSpot, client akan terputus dari HotSpot jika uptime tercapai.
  • Limit Bytes In, Jumlah maksimal byte (total quota download) yang dapat diterima oleh client. Client akan terputus dari HotSpot setelah batas tersebut tercapai.
  • Limit Bytes Out, Jumlah maksimal byte (total quota upload) yang dapat diterima oleh client. Client akan terputus dari HotSpot setelah batas tersebut tercapai.
  • Limit Bytes Total, Jumlah maksimal byte (total quota download & upload) yang dapat diterima oleh client. Client akan terputus dari HotSpot setelah batas tersebut tercapai.

User Profiles - /ip hotspot user profile

Dibagian ini ada beberapa option yang bisa Anda konfigurasi
Tab “General

 

  • Name, nama user profile
  • Shared User, seberapa bnyak user yang bisa online dengan 1 username.
  • Rate limit, limitasi bandwidth download & upload per user.

Beberapa Contoh Membuat User Hotspot MikroTik

Cara Membuat Username dengan Limit Bandwidth Internet

Anggap saja kita akan membuat batasan kategori user hotspot sebagai berikut :

  • User VIP, dengan batasan kecepatan koneksi internet Download 1Mbps dan Upload 384Kbps.
  • User Gold, dengan batasan kecepatan koneksi internet Download 512Kbps dan Upload 256Kbps.
  • User Silver, dengan batasan kecepatan koneksi internet Download 256Kbps dan Upload 128Kbps.

Yang pertama kita lakukan adalah membuat User Profile pada hotspot mikrotik kita.

# jun/30/2014 14:33:16 by RouterOS 5.26 # Adam Rachmad - http://adamonline.web.id /ip hotspot user profile add advertise=no idle-timeout=none keepalive-timeout=2m name=VIP \     open-status-page=always rate-limit=512k/1m shared-users=1 \     status-autorefresh=1m transparent-proxy=yes add advertise=no idle-timeout=none keepalive-timeout=2m name=Gold \     open-status-page=always rate-limit=256k/512k shared-users=1 \     status-autorefresh=1m transparent-proxy=yes add advertise=no idle-timeout=none keepalive-timeout=2m name=Silver \     open-status-page=always rate-limit=128k/256k shared-users=1 \     status-autorefresh=1m transparent-proxy=yes

1

2

3

4

5

6

7

8

9

10

11

12

# jun/30/2014 14:33:16 by RouterOS 5.26

# Adam Rachmad - http://adamonline.web.id

/ip hotspot user profile

add advertise=no idle-timeout=none keepalive-timeout=2m name=VIP \

    open-status-page=always rate-limit=512k/1m shared-users=1 \

    status-autorefresh=1m transparent-proxy=yes

add advertise=no idle-timeout=none keepalive-timeout=2m name=Gold \

    open-status-page=always rate-limit=256k/512k shared-users=1 \

    status-autorefresh=1m transparent-proxy=yes

add advertise=no idle-timeout=none keepalive-timeout=2m name=Silver \

    open-status-page=always rate-limit=128k/256k shared-users=1 \

    status-autorefresh=1m transparent-proxy=yes

Di Winbox akan terlihat seperti ini IP > Hotspot > User Profiles :

user_profile_hotspot_mikrotik

Setelah itu baru kita buat username dan password untuk kategori user hotspot yang barusan kita buat.

# jun/30/2014 14:33:16 by RouterOS 5.26 # Adam Rachmad - http://adamonline.web.id /ip hotspot user add disabled=no name=udin password=123456 profile=VIP server=hotspot1 add disabled=no name=petot password=123456 profile=Gold server=hotspot1 add disabled=no name=jiung password=123456 profile=Silver server=hotspot1

1

2

3

4

5

6

# jun/30/2014 14:33:16 by RouterOS 5.26

# Adam Rachmad - http://adamonline.web.id

/ip hotspot user

add disabled=no name=udin password=123456 profile=VIP server=hotspot1

add disabled=no name=petot password=123456 profile=Gold server=hotspot1

add disabled=no name=jiung password=123456 profile=Silver server=hotspot1

Terlihat di winbox akan seperti ini IP > Hotspot > Users :

user_hotspot_mikrotik

Sekarang coba login dengan salah satu username passsword tersebut, contoh saya coba login dengan user hotspot “udin” kategori user hotspot VIP.

queue_user_hotspot

Terlihat pada gambar di atas bahwa client yang login dengan username “udin” ter limit kecepatannya disesuaikan user profile yang sebelumnya kita buat. Ini berlaku untuk user hotspot lainnya. Di winbox kita bisa lihat di Queues > Simple Queues.

Otentifikasi Login Hotspot Dengan MAC Address Komputer/Laptop Client

Disini kita akan mencoba bagaimana agar komputer/laptop client bisa login otomatis dengan identifikasi MAC Address. Jadi user hotspot tidak perlu username password untuk bisa login ke hotspot mikrotik kita. Ini berbeda dengan fitur Binding/Bypass MAC Address.

Pertama, kita set dulu Server Profilesnya agar bisa otentifikasi dengan mac, IP > Hotspot > Server Profiles > pilih profile yang anda gunakan > tab Login > centang MAC.

enable_mac_login_hotspot

Kemudian buat user IP > Hotspot > Users > add dan isi Name dngan MAC address client dan tentukan User Profilesnya.

otentifikasi_by_mac_hotspot

Client/user tidak akan melihat halaman login hotspot mikrotik Anda, tapi di status mikrotik kita aktif. Dan limitasi mengikuti user profile yang kita tentukan.

enable_mac_login_hotspot2

Cara username hanya bisa digunakan untuk login di MAC Address yang ditentukan

Anggap anda ingin 1 username password bisa digunakan untuk login di 1 MAC Address, jadi komputer/laptop yang mempunyai MAC address berbeda tidak bisa menggunakan username ini. Berikut adalah cara settingnya :

/ip hotspot user add disabled=no mac-address=08:00:27:00:A8:E9 name=udin password=123456 profile=VIP \     server=hotspot1

1

2

3

/ip hotspot user

add disabled=no mac-address=08:00:27:00:A8:E9 name=udin password=123456 profile=VIP \

    server=hotspot1

Jadi username dengan nama “udin” hanya bisa digunakan di komputer/laptop yang mempunyai MAC Address 08:00:27:00:A8:E9. Jika digunakan di berbeda mac address akan tampil error message seperti dibawah ini :

mac_address_login_hotspot

 

 

Untitled Document